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Introduction 

This document introduces the V2024.0 release of the ACE+ Suite of applications. It 

summarizes the new features, enhancements and the list of issues that are corrected since 

the V2023.0 release. 

ACE+ SUITE of Applications 

The ACE+ SUITE package includes applications that provide the necessary tools for advanced 

multiphysics analysis in a virtual prototype environment. The complete list of applications is 

shown below: 

• CFD-GEOM  

• CFD-VisCART  

• CFD-ACE+ 

• CFD-FASTRAN 

• CFD-TOPO 

• SimManager  

• CFD-VIEW  

• CFD-Toolkit 
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Supported Platforms  

ACE+ SUITE V2024.0 is supported on the following platforms:  

 

Platform Package Canonical Name 

Windows 10 on Intel or AMD (64-bit) windows-x64-intel19-msvc142-

md 

Linux RedHat Enterprise 7+ on Intel or AMD 

(64-bit)   

linux-x64-intel19-glibc2.17 

Linux RedHat Enterprise 8+ on Intel or AMD 

(64-bit) 

linux-x64-intel19-glibc2.28 

 

 

 • ACE+ SUITE is not supported on 32-bit platforms (Windows or Linux). 

• If you are not using installers provided by Applied Materials, ensure that 

you have the right directory structure.  
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User Subroutine - Intel FORTRAN Compiler Versions 

In the table below, the Applied Materials ACE+ Version indicates the version from which a 

particular Intel FORTRAN Compiler or Visual Studio is supported until replaced with a newer 

version: 

 

ACE+ 

Version 

Intel Compiler 

Version (Linux) 

Intel Compiler Version 

(Windows) 

Visual Studio Version 

(Windows) 

2023.0 2020.0 2020.0 VS2019 

 

  

The table below displays the legacy ESI ACE+ Versions and supported Intel FORTRAN 

Compiler or Visual Studio versions and is provided for informational purposes only. 

 

ACE+ 

Version 

Intel Compiler 

Version (Linux) 

Intel Compiler Version 

(Windows) 

Visual Studio Version 

(Windows) 

2013.0 2011.1 2011.1 VS2008 

2013.4 2011.1 2011.1 VS2010 

2015.0 2015.3 2015.3 VS2010 

2017.0 2015.3 2015.3 VS2013 

2017.5 2016.4 2016.4 VS2013 

2018.5 2016.4 2016.4 VS2015 

2021.0 2020.0 2020.0 VS2019 
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Running Older Versions 

Multiple versions of ACE+ SUITE can in general be installed and run in parallel. However, 

please note that the legacy ESI ACE+ Versions and the Applied Materials ACE+ Suite requires 

different licenses. 

Environment Requirement 

If you install V2024.0 software alongside previously installed older version(s), modify your 

PATH environment variable so that the newest UTILS\bin directory appears first in your 

PATH.  

Then, it is possible to run older versions of the software using the -runver <version> option 

from the command prompt or from the MS Windows Start > Run app. 

 

Example CFD-GEOM –runver 2021.0 

This command will launch CFD-GEOM software V2021.0. 

 

  

To use -runver option with both the legacy ESI ACE+ versions and Applied Materials ACE+ 

Suite, it is recommended that the users install both the software in the same directory. This 

enables the environment variables ESI_HOME (used by the legacy version) and 

ACE_SUITE_HOME (used by the new versions) to be the same. 

License Requirement 

You will need a V2024.0 or later license to run V2024.0 applications. 

Flexnet V11.19.1 (provided in this package or downloadable from the Applied Materials 

Portal) should be used for the V2023.0 and later applications to work. 

• Install the FNP Licensing Service (install_FNP) provided in the toolkit. 

• Run the getLmHostIds program (from a terminal) to get the host information needed 

for license generation. 

• Use the lmadmin program to install and administer the license. Refer to the 

README.txt file and the fnp_LicAdmin.pdf manual within the Flexnet toolkit for 

detailed instructions. 

https://amat.account.box.com/login
https://amat.account.box.com/login
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Installation 

This section summarizes the main steps to install ACE+ SUITE. 

Installing ACE+ SUITE on Windows 

1. Extract the ACE+Suite_V2024.0_Windows-x64.zip archive to a temporary 

directory. 

2. Click setup.exe and follow on-screen instructions. 

The installer will install the necessary packages and set up the environment variables 

(ACE_SUITE_HOME and PATH). 

Installing ACE+ SUITE on Linux 

1. Extract the ACE+Suite_V2024.0_Linux-x64-glibc2.17.tar.gz (for RHEL 7) or 

ACE+Suite_V2024.0_Linux-x64-glibc2.28.tar.gz (for RHEL 8) archive to a 

temporary directory. 

2. From within the extracted directory, run install.com and follow on-screen 

instructions to complete installation. 

3. Login as the end user and run configure_user_account.sh to setup the necessary 

environment variables (ACE_SUITE_HOME and PATH). 

Manually Setting Up Environment Variables 

1. Set the ACE_SUITE_HOME environment variable. This defines the directory where the 

software is installed: 

o Windows: 

ACE_SUITE_HOME = C:\Program Files\Applied_Materials 

o Linux – BASH: 

export ACE_SUITE_HOME=/usr/local/Applied_Materials 

o Linux – CSH: 

setenv ACE_SUITE_HOME /usr/local/Applied_Materials 
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2. Set the PATH environment variables. They should reflect the new path to UTILS/bin. 

o Windows : 

Variable Name: PATH  

Value: %ACE_SUITE_HOME%\ACE+Suite\2024.0\UTILS\bin 

o Linux – BASH : 

Variable Name: PATH  

Value: $ACE_SUITE_HOME/ACE+Suite/2024.0/UTILS/bin 

Command: export 

PATH=$ACE_SUITE_HOME/ACE+Suite/2024.0/UTILS/bin:$PATH 

o Linux – CSH: 

Variable Name: PATH 

Value: $ACE_SUITE_HOME/ACE+Suite/2024.0/UTILS/bin 

Command: setenv PATH 

$ACE_SUITE_HOME/ACE+Suite/2024.0/UTILS/bin:$PATH 
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New Features and Enhancements 

This chapter describes the new features and improvements of ACE+ SUITE V2024.0 release. 

CFD-GEOM ..................................................................................................................... 7 
CFD-VisCART .............................................................................................................. 13 
CFD-ACE+  .................................................................................................................... 18 
CFD-TOPO .................................................................................................................... 27 

CFD-GEOM 

CFD-GEOM V2024.0 includes the following new features and enhancements. Please refer to 

the ACE+ SUITE 2024.0 CFD-GEOM User's Guide for further details. 

Enhanced Performance for Rendering Large and Complex Models 

V2024.0 CFD-GEOM significantly improves the speed and efficiency of graphical rendering 

for large and complex models, ensuring a smoother and more responsive experience. An 

alternate texture-based method has been introduced to draw the lasso box and avoid 

graphical artifacts. 

The latest release also introduces a major performance improvement in the performance of 

transformation operators, including translate, rotate, scale and scale all. Users will now 

experience faster and more accurate previews, while also benefiting from reduced memory 

usage. 

A new, optional selection mode, specifically for faster selections in large models, has been 

introduced. Currently, CFD-GEOM has one selection mode that is software-based method 

and selects entities based on mouse click or lasso. With the new tool, objects obscured by 

closer objects will not be selected. Thus, a single click will only return the closest object and 

nothing else while a lasso selection will only select the non-obscured objects. A new button 

is added to the main toolbar to switch selection modes. This setting will be retained in the 

global settings and will be set/unset on a new invocation of CFD-GEOM. 

 

Figure 5-1:  Fast Selection Mode 
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CFD-GEOM supports up to 10 quick views with custom names. These views are saved in the 

GGD file and can be recalled using short cuts. To create and save a view, use Ctrl + Alt + 

(0-9). You can manage the names by right clicking in the graphical viewer and select Quick 

Views > Manage Names. To recall and activate a view, use Ctrl + (0-9). 

  

 

Figure 5-2:  Save and restore Quick views with custom names 

The current model tree displays each entity in their own folders. However, the ordering is 

based on the order of creation. Now, CFD-GEOM will order the items in each folder 

alphabetically according to assigned names, thus, making it easier to locate items. In 

addition, meshed solids are now highlighted through a different icon. 

  

 

Figure 5-3:  Model tree enhancements 
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Selective Part Import Capability 

CFD-GEOM supports the import of CAD models in different formats. In current versions, the 

whole model is imported. However, there are situations when it is necessary to import only 

a subset of the parts in the CAD model. This may be necessitated by the need to focus on 

repairing a component or replacing a part in a design study. 

The file import dialog has been updated with a new Allow Selective Import option. 

Upon enabling selective import, a dual graphics window interface is presented. The left side 

displays all parts of the CAD model. Users can select desired parts on the left side and then 

move it to the right side for importing into CFD-GEOM. 

Accompanying this new option is the ability to generate thumbnails for various parts of the 

CAD model. This visual aid can enhance the selection process for some models. 

Beside facilitating selective importing, the dual viewer setup also serves as a tool to 

interrogate and understand a model before importing into CFD-GEOM. 

The selective import feature is also available while replacing parts in CFD-GEOM. 

  

 

Figure 5-4:  Selective import of parts 

New Solid Inversion Tool 

The Invert Model tool in CFD-GEOM allows users to extract fluid domains from a 3D CAD 

model. This tool works on the entire model and not just a subset. For large models, this could 

cause the creation of hundreds of unneeded domains. Other limitations include not working 

with non-planar holes and not supporting undo/redo of the inversion operation. A new 

method is added to this tool which removes the above-mentioned limitations. 
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To invoke this tool, select the Selected Domains Inversion Type. Then, select a subset of 

available unstructured domains. Immediately, all possible capping surfaces are displayed, 

and all remaining surfaces are hidden. Select relevant bounding surfaces which reveals holes 

formed by the bounding surfaces and apply to perform the inversion operation. 

The new method works with non-planar surfaces and supports undo/redo operations. 

  

 

Figure 5-5:  Unstructured domain inversion tool 

Improved Cut Section Tool 

A new cut section tool was introduced in V2023.0. This tool has been improved in V2024.0. 

Users can expect faster performance for larger models. Along with enhanced graphics, 

display of outlines of the cut section and automatic clipping of the region away from the cut 

plane is enabled. Interactive distance measurement on the cut sections is now possible on 

the cut section or the model. This tool now serves two purposes, the first being to create 

arbitrary planar cut sections in solids and secondly for visualization to interrogate models. 

  

 

  

Figure 5-6:  Cut section tool 
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Meshing Improvements 

An expansion factor for Advancing Front (AF) Surface meshing has been added to allow the 

user to obtain a mesh with fewer interior elements. 

  

 

Figure 5-7:  Advancing Front surface meshing tool 

The following additional performance improvements are available with the Advancing Front 

(AF) Surface meshing option in CFD-GEOM. 

1. Improved interior curvature resolution. 

2. Improved mesh element sizes when using Octree background for sizing. 

3. Advancing Front Tetrahedral meshing performance improvements to generate 60K to 

300K more elements per minute. 

  

Additional Robustness and Performance Improvements 

A revised distance measurement tool is now available to interactively interrogate feature 

sizes with improved performance for minimum distance tool, especially for large models. 

A revised 3D mesh quality tool for Unstructured Domains, Semi-structured domains, and 3D 

Structured blocks is now available. Entities which violate a given quality criteria will now be 

highlighted and pressing Ctrl + r will hide all other visible entities. 

A bug fix for reading large python scripts significantly reduces time for models with large 

number of geometric entities. 
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Improved handling of spherical and conical surfaces to eliminate trimming failures. 

File import times for large CAD models is faster and robust. Users no longer need to 

iteratively change parameters to obtain the cleanest import for most models. 
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CFD-VisCART 

CFD-VisCART V2024.0 includes the following new features and enhancements. Please refer 

to the ACE+ SUITE 2024.0 CFD-VisCART User's Guide for further details. 

  

Selective Part Import Capability 

CFD-VisCART supports the import of CAD models in different formats. In current versions, 

the whole model is imported. However, there are situations when it is necessary to import 

only a subset of the parts in the CAD model. This may be necessitated by the need to focus 

on repairing a component or replacing a part in a design study. 

The file import dialog is updated with a new Partial importing by selecting parts option. Upon 

enabling selective import, a dual graphics window interface is presented. The left side 

displays all parts of the CAD model. Users can select desired parts on the left side and then 

move it to the right side for importing into CFD-VisCART. 

Beside facilitating selective importing, the dual viewer setup also serves as a tool to 

interrogate and understand a model before importing into CFD-VisCART. 

  

 

Figure 5-8:  Selective import of parts 

Save and Restore View Quickly 

CFD-VisCART now allows to save and restore up to 10 views of a model. These views can have 

unique names and will be stored in the .VGD file when saved. These options can be invoked 
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from View > Save view or View > Switch view. The same options can also be 

accessed using shortcuts (CTRL+ALT+(0-9) to save view and CTRL+(0-9) to restore view). 

  

 

Figure 5-9:  Save and restore view 

  

Enhancements Related to Solids/Groups 

1. Groups/Solids can now be sorted in ascending, descending or the original (default) 

order. 

2. When a surface is selected in GUI, the Group/Solid to which it belongs, will be 

highlighted in the explorer. If the surface belongs to both Group and Solid, then Group 

takes precedence and will be highlighted. 

3. 3. When a surface is selected in GUI, Group Blanking/Solid Blanking options (Hide, 

Show, Hide Others, and Inverse Visibility) can be invoked from the right-

click menu. Hide, Show and Hide Others work as the name suggests. Inverse 

Visibility will inverse the groups/solids displayed in GUI. 

4. When cursor is hovered over Group(s) or Solid(s) panel, the status bar shows the count 

of Groups and Solids in the model. 

5. 5. While grouping/regrouping surfaces, the option Remove selected item(s) from 

old group is introduced to prevent duplicates. 
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Figure 5-10:  Prevent duplicates while grouping 

  

6. The explorer search tool has been enhanced to restrict search for surfaces to specified 

solids in the model. A new operator keyword “solid:” can be used to restrict searches 

to specific solids in the model. For example, solid:solid_1 name:surface_1 will look for 

objects with name surface_1 within the solid “solid_1”. 

  

 

Figure 5-11:  Enhanced search tool – additional operator keywords 

  

 

Figure 5-12:  Enhanced search tool - usage 

Cylindrical Source Enhancements 

The cylindrical source detection capability in CFD-VisCART allows users to identify and apply 

mesh refinement sources on multiple similar cylindrical components such as those in 

showerhead holes. This capability has been enhanced to handle non-flat (slanted) top or 

bottom surfaces. In addition, once cylindrical sources are detected, the height of the sources 
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can be extended downstream beyond the cylinder to have smooth mesh transition to 

capture important flow features. The direction of the extension can be reversed using the 

"Reverse Direction" option. All similar cylindrical sources will be oriented in the same 

direction of the parent cylindrical source. 

  

 

Figure 5-13:  Enhanced cylinder source for mesh refinement 

  

Export a Subset of Domains to DTF 

CFD-VisCART, in previous versions, exported all meshed domains to DTF and users did not 

have control over which ones to export. This is useful in large models where a user may be 

interested in testing a subset of the model. Users can now right-click on selected domains 

and use the option, Save Selected Domain Mesh to DTF, and export a subset of meshed 

domains to DTF. 
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Figure 5-14:  Export subset of domains to DTF 

Additional Performance and Robustness Improvements 

1. Distance measurement has been enhanced to support measurement between a point 

and a surface (in addition to the previously supported options to measure distance 

between two points or a point and a line). 

2. Renaming of multiple patches is supported now. When multiple patches are selected, 

CFD-VisCART will auto-generate and add a number to the given new patch name as a 

suffix. 

  

 

Figure 5-15:  Rename multiple patches 

3. CFD-VisCART now allows to modify patches even after meshing. This enables users to 

combine/split patches before writing to the DTF file. 

4. Part names are now read and preserved for Parasolid Import. 
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CFD-ACE+  

CFD-ACE+ V2024.0 includes the following new features and enhancements.  

Please refer to the ACE+ SUITE 2024.0 CFD-ACE+ User's Guide for further details. 

Improvements to Parametric Study Capability 

CFD-ACE+ supports the use of parameters on most inputs. These parameters can then be 

used as part of a parametric study to evaluate the effects of varying such parameters within 

a given range of values. In recent releases, this capability has been extended to some of the 

inputs in the database, particularly, the ability to vary mixture flow rates (SLM or SCCM). In 

this release, this has been extended to volume and surface reaction parameters - Pre-

exponential Factor (Ap), Activation Temperature (Ea/R), Temperature Exponent (n), Pressure 

Exponent (m) and Sticking Coefficient (Sc). 

To set these inputs as parameters, select Tools > Parameters and Expressions > Parametric 

Reactions. A list of volume and surface reactions in the model will be displayed. For each 

reaction, users can set any of the available input as a parameter. Note that Sticking 

Coefficient is applicable only for surface reactions and the pressure exponent is not available 

as a parameter for surface reactions. 

  

 

Figure 5-16:  Parametric reactions 

In previous versions, cases in a parametric study will run sequentially and post-processed 

for any Visualization Expressions setup in the model (done through the Viz tab) as soons as 

the run is complete. From this release, parametric studies can run multiple cases 
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simultaneously. The maximum number of concurrent runs can be controlled from Edit > 
Preferences > Parametric Studies > Maximum number of concurrent solver 

runs. 

  

 

Figure 5-17:  Concurrent runs for parametric studies 

Each concurrent run requires an additional solver license. Each case can also be run in 

parallel mode using mpi and / or threading and would use necessary licenses. 

Reinstatement of Structural Dynamics Module 

Due to certain licensing issues, the structural dynamics module was disabled in the 2023.0 

version. This limitation has been removed. Users can avail the use of this module again from 

this release. 

In previous versions, all solid domains involved in stress simulations must be part of a single 

process in a parallel run (other modules may be run in multiple processes). This limitation 

has been removed and the module is now supported in parallel. 

Certain features of the module are still unavailable (modal analysis) and will become 

available in future releases. If solid shell elements have multiple elements across the 

thickness and these elements are on different processors, parallel mode is not supported. 

  

Improvements to Heat Transfer Modeling 

The Thin Wall Boundary Condition simulates physical features such as baffles, plates, and 

heat resistances whose thickness is so thin as to be essentially ignorable from a grid 
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generation perspective, but not from a momentum, heat transfer, and/or scalar transport 

standpoint. In recent versions, CFD-ACE+ had added support for multi-layer thin walls and 

solid borders while allowing variations in thin wall thickness and account for temperature 

dependent variations in thermal conductivity. However, the underlying formulation was a 

steady-state approximation even in transient simulations. In this release, this limitation has 

been removed. Users will additionally input Specific Heat and Density of the material 

involved. 

  

 

Figure 5-18:  Thin wall specification for transient runs 

In CFD-ACE+ Thin Wall Boundary Condition, a higher fidelity contact resistance calculation 

may be made with the addition of thermal gap modeling. This model is used to calculate the 

heat transfer between solid bodies separated by a gap. The thermal gap model accounts for 

gaseous conduction within the gap, the effects of direct-contact conduction (solid-solid 

conduction), and radiation across the gap. In previous versions, users had to specify one 

emissivity value for the gap model. In situations, where there are materials with different 

emissivities on each side of the thin wall, users had to calculate an effective emissivity for the 

thermal gap. In this version, users will have the option to specify the emissivities of each side 

directly in GUI. 

If users wish to specify the emissivities on either side of the thin wall directly, uncheck the 

Use the same emissivity for both sides check box, and specify the values for the 

near side and far side emissivities. The near side is represented by a yellow arrow and the 

far side is represented by a red arrow. Use the Reverse Sides check box to switch 

directions (also reflected by the arrows). 
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Figure 5-19:  Thermal gap model – emissivity specifications 

Spectral properties calculated during a Monte Carlo radiation simulation can be written to a 

file by checking Spectral Properties check box in Out > Adv. This issue has been corrected 

and the calculated Planck-averaged transmittance data is correctly written to the MC file. 

  

 

Figure 5-20:  Writing calculated spectral properties to an external file 

When Out > Summaries > Energy Balance Summary > Monitor Energy Imbalance 

is switched on, energy imbalance data is written to the *_IQ.MON file at every iteration. 

However, a previous bug prevented the inclusion of volumetric heat sources at every 

iteration. Instead, it was added only when a DTF was written out. This issue has been 

corrected to include volumetric heat sources at each iteration. Note that this issue was 

restricted to the *_IQ.MON file only and does not affect the simulation results itself. 

Improvements to Chemistry Modeling 

Thermo diffusion, also known as Soret Diffusion, accounts for diffusion that arise due to 

temperature gradients. Corrections and improvements have been made to the temperature 

gradient calculations and the Soret source term, potentially improving accuracy and 

convergence. 
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In Finite-Rate (Species Approach in Gas Phase) - Multistep reaction with Third Body (M) and 

pressure dependency, users have the option of providing parameters for pressure fall-off 

reactions. In CFD-ACE+, Unimolecular/Recombination and Chemically Activated reactions are 

allowed with different blending functions. A defect prevented the parameters from being 

read for Unimolecular/Recombination reactions. This issue has been corrected along with 

minor improvements to the output. 

  

 

Figure 5-21:  Pressure fall-off reactions specifications 

Users can now monitor mole fractions through the monitor points facility of CFD-ACE+. 

Previously, it was restricted to Species Mass Fractions (Gas Phase) or Species Concentration 

(Liquid Phase). This can be used as an additional way of ensuring that a case has converged. 

  

 

Figure 5-22:  Monitor Species Mole Fractions 

For Species Mass Fraction monitor points, users may also notice that values less than 1E-30 

are now written as 0 to address certain format / plotting issues. 

In some cases, with Species Mass Fractions monitor points, the solver may crash during a 

parallel run in previous versions. These issues have also been addressed. 

The Profile in Time for mixture specification allows users to easily input ALD type inlet 

boundary conditions. Users can input the different steps of an ALD cycle easily and specify 

the number of cycles to simulate. Several corrections and improvements have been made to 
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ensure that the specified input table (time steps and mixture flow rates) is honored. Note 

that at this time, input to the table is the ratio of a mixture as compared to its value specified 

in the database. In general, the solver linearly interpolates between the two rows in the table 

within which the current simulation time falls and an exact timestep size of zero is currently 

not possible. Therefore, a small timestep size is needed even for a step change in gas 

mixtures. For cycles involving such step changes, it is recommended to use Auto Time Step 

over the Standard Time Step scheme because of the flexibility it provides to adjust timestep 

sizes and keep it closer to the actual inputs. 

  

 

Figure 5-23:  Profile in time for mixtures 

In the table shown above, for example, the first row should be interpreted as: 

1.680690889 * SLM (or) SCCM specified in the database for MIX_1 (which is Mixture_1_BDA) 

+ 

1.0 * SLM (or) SCCM specified in the database for MIX_2 (which is Mixture_2_AR) + 

1.0 * SLM (or) SCCM specified in the database for MIX_3 (which is Mixture_3_O2) 

The solver calculated values at each time step is also printed to the .OUT file. 

  

 

Figure 5-24:  Output of calculated inputs for species 
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Improvements to Multiphase Modeling 

CFD-ACE+ Two Fluid module offers two solution approaches for handling phase change 

problems, the General method, and the Enthalpy method. For the Enthalpy method, Phase 

change properties of Saturation temperature and Latent Heat of Vaporization are provided 

in MO > Fluid2 and these properties remain the same for all applicable two-fluid volume 

conditions. However, in some scenarios, the ability to specify different phase change 

properties for different volumes can be useful. For example, 

• Different phase change properties can be used in problems where the volumes are 

physically separated from each other and have distinct phase-change behaviors. 

Examples include microchannel heat exchangers having disconnected hot-fluid paths 

and cold-fluid paths. It is expected that the disconnected paths may have different gas-

liquid properties and phase change properties. 

• The ability to provide different phase change properties can also be useful to turn OFF 

the Enthalpy-based phase-change in a specific volume by setting the Saturation 

Temperature and Latent Heat of Vaporization to extreme values. This could aid in 

convergence of the overall problem when no phase-change is occurring in certain 

volumes. 

  

Enthalpy method in CFD-ACE+ V2024.0 now allows the user to specify different Phase Change 

properties for each volume condition. 

  

 

Figure 5-25:  VC-by-VC specification of phase change properties 

The Spray Module tracks a discrete phase (liquid droplets, solid particles, or bubbles) through 

the calculation domain. An incomplete time integration for the drops when crossiing over 

across process boundaries in parallel simulations, caused incorrect trajectory calculations 

for some parcels in the simulation. This issue has been corrected and the correct parcel 

locations are calculated even after crossing processor boundaries. 

Improvements to Plasma Modeling 

Energy and angular distribution (EADF) files can be written out by CFD-ACE+ feature scale 

output for each ion species, if a sheath model is activated in a plasma reactor scale 
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simulation. This capability has been extended to CCP simulations. To enable writing the 

combined EADF file. 

1. Restart from a converged CCP simulation 

2. Enable Monte Carlo Transport to Compute IEADFs (MO > Plasma > Monte Carlo 

Transport) 

  

 

Figure 5-26:  Enabling Monte Carlo Transport 

3. Set Number of bins, Energy range and Angular range 

4. Select MC Output points (BC > Output > Plasma > Monte Carlo Transport > 

Select locations for IEADF Computation) 

  

 

Figure 5-27:  Node selection for MC transport 

In addition to the EADF files, ion flux information is also needed by CFD-TOPO solver. This is 

enabled from Out > Adv > Feature Scale Coupling. Here, users can choose to manually specify 

a set of points (User Input), Read from a file or Use Monte Carlo Transport Locations. The 

later would use the same points as specified in BC > Output > Plasma > Monte Carlo 

Transport > Select locations for IEADF Computation. 

  

 

Figure 5-28:  Use MC transport location for feature scale coupling 
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Users can now optionally save the Electric Field calculated during a Monte Carlo Transport 

computation for IEADFs. During subsequent MC runs, users can use the saved Electric Field 

and run the IEADF calculations. 

  

 

Figure 5-29:  Save electric fields or reuse save electric fields in MC transport 

MC simulations use a sub-mesh around the chosen output points to minimize computational 

cost. In some circumstances, this sub-mesh may need to be extended to ensure good 

statistics. Users can now change this sub-mesh directly from the GUI Out > Adv > Plasma > 

Specify Sub-Mesh Dimensions and enter the X and Y dimensions. 

  

 

Figure 5-30:  Sub-Mesh specification for MC transport 
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CFD-TOPO 

CFD-TOPO V2024.0 includes the following new features and enhancements.  

  

Please refer to the ACE+ SUITE 2024.0 CFD-ACE+ User's Guide for further details. 

Improvements to Multi-layer Multi-material Deposition 

CFD-TOPO predicts how the shapes of objects will change due to the combined effects of 

chemical species transport and surface reaction at gas-solid interfaces. CFD-TOPO is 

applicable for predicting the effects of depositing into, or etching from, relatively small 

topographical features by gas-phase processes such as chemical vapor deposition or 

plasma-enhanced etching. 

CFD-TOPO can address the deposition and/or etching of multiple materials. However, the 

data structure implicitly assumes a 1:1 matching between level set functions and solid 

materials. If the same material is deposited a second time, users may have to manually 

restart using results from a previous step, which is not convenient. In this release, CFD-TOPO 

data structure has been upgraded to allow multiple level set functions for a given solid 

material within the model domain. Now, users can simulate processes in which multiple 

layers of varying materials are deposited in a feature, including possibly repeating layers of 

one or more materials and/or intermediate etch steps. 

  

 

Figure 5-31:  Multilayer deposition and etch process 
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Support for Parallel 

Modern high aspect ratio features, or multiple material deposition and etching simulations 

impose several challenges for simulations. There is an increased necessity for rapid 

turnaround time in such simulations to enable large parametric evaluations. CFD-TOPO 

solver has been upgraded to support parallelization through threading. The maximum 

number of threads to be used can be set from Edit > Preferences > General > Performance 

> Maximum number of solver threads. 

  

 

Figure 5-32:  Number of threads for TOPO solver 

Improvements to Scripting and Parametric Studies 

Though a preliminary scripting capability was present in previous versions of CFD-TOPO, it 

did not support certain section of the application (e.g. RC tab). These limitations have been 

addressed and CFD-TOPO supports scripting for all features. 

Similar to CFD-ACE+, CFD-TOPO now supports the ability to do parametric studies. Users can 

mark most input fields as a parameter and include it in a parametric study. This also extends 

to certain database parameters such as Pre-exponential Factor (Ap), Activation Temperature 

(Ea/R), Temperature Exponent (n) and Sticking Coefficient (Sc). 
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Figure 5-33:  Parametric study setup in CFD-TOPO 

During a parametric study, multiple cases can be run concurrently. The maximum number 

of concurrent jobs can be set in Edit > Preferences > General > Parametric Studies > 

Maximum number of concurrent solver runs. 

  

 

Figure 5-34:  Concurrent runs for parametric studies 
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